don't touch TAR_OPTIONS in host.mk
[openwrt.git] / toolchain / Config.in
index 3f0d13f..7b0a0aa 100644 (file)
@@ -1,7 +1,14 @@
 #
+config NATIVE_TOOLCHAIN
+       bool
+       prompt "Use host's toolchain" if DEVEL && BROKEN
+       default n
+       help
+               If enabled, OpenWrt will compile using your existing toolchain instead of compiling one
 
 menuconfig TOOLCHAINOPTS
        bool "Toolchain Options" if DEVEL
+       depends !NATIVE_TOOLCHAIN
 
 source "toolchain/binutils/Config.in"
 source "toolchain/gcc/Config.in"
@@ -13,13 +20,6 @@ config GDB
        help
                Enable if you want to build the gdb
 
-config ENABLE_MULTILIB
-       bool
-       prompt "Enable multilib support?" if TOOLCHAINOPTS
-       default n
-       help
-           If you want multilib enabled, enable this...
-
 config LARGEFILE
        bool
        prompt "Enable large file (files > 2 GB) support?" if TOOLCHAINOPTS
@@ -46,7 +46,9 @@ config TARGET_OPTIMIZATION
        prompt "Target Optimizations" if TOOLCHAINOPTS
        default "-Os -pipe -march=i486 -funit-at-a-time" if i386
        default "-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time" if mipsel || mips
+       default "-Os -pipe -mcpu=xscale -funit-at-a-time" if armeb
        default "-Os -pipe -funit-at-a-time"
        help
          Optimizations to use when building for the target host.
 
+source "toolchain/gcc/Config.version"