xburst: mark the asoc modules as BROKEN until the upstream fixes get merged
[openwrt.git] / target / linux / xburst / modules.mk
index 0e886b5..95cebda 100644 (file)
@@ -4,7 +4,7 @@ SOUND_MENU:=Sound Support
 
 define KernelPackage/sound-soc-jz4740
   SUBMENU:=$(SOUND_MENU)
-  DEPENDS:=kmod-sound-soc-core @TARGET_xburst
+  DEPENDS:=kmod-sound-soc-core @TARGET_xburst @BROKEN
   TITLE:=JZ4740 SoC sound support
   KCONFIG:=CONFIG_SND_JZ4740_SOC CONFIG_SND_JZ4740_SOC_I2S
   FILES:= \
@@ -15,7 +15,7 @@ endef
 
 define KernelPackage/sound-soc-jz4740-codec
   SUBMENU:=$(SOUND_MENU)
-  DEPENDS:=kmod-sound-soc-core @TARGET_xburst
+  DEPENDS:=kmod-sound-soc-core @TARGET_xburst @BROKEN
   TITLE:=JZ4740 SoC internal codec support
   KCONFIG:=CONFIG_SND_SOC_JZ4740_CODEC
   FILES:=$(LINUX_DIR)/sound/soc/codecs/snd-soc-jz4740-codec.ko
@@ -24,7 +24,7 @@ endef
 
 define KernelPackage/sound-soc-xburst/default
   SUBMENU:=$(SOUND_MENU)
-  DEPENDS:=kmod-sound-soc-jz4740 kmod-sound-soc-jz4740-codec @TARGET_xburst_$(if $(4),$(4),$(3))
+  DEPENDS:=kmod-sound-soc-jz4740 kmod-sound-soc-jz4740-codec @TARGET_xburst_$(if $(4),$(4),$(3)) @BROKEN
   TITLE:=$(1) sound support
   KCONFIG:=CONFIG_SND_JZ4740_SOC_$(2)
   FILES:=$(LINUX_DIR)/sound/soc/jz4740/snd-soc-$(3).ko