x86: declare missing kernel symbols
[openwrt.git] / target / linux / x86 / modules.mk
index 7826dc8..f8cb3a7 100644 (file)
@@ -122,7 +122,7 @@ $(eval $(call KernelPackage,gpio-nsc))
 define KernelPackage/gpio-pc8736x
   SUBMENU:=$(OTHER_MENU)
   TITLE:=PC8736x GPIO support
-  DEPENDS:=@TARGET_x86
+  DEPENDS:=@TARGET_x86 +kmod-gpio-nsc
   KCONFIG:=CONFIG_PC8736x_GPIO
   FILES:=$(LINUX_DIR)/drivers/char/pc8736x_gpio.ko
   AUTOLOAD:=$(call AutoLoad,40,pc8736x_gpio)
@@ -280,3 +280,51 @@ define KernelPackage/i2c-scx200-acb/description
 endef
 
 $(eval $(call KernelPackage,i2c-scx200-acb))
+
+
+define KernelPackage/leds-wrap
+  SUBMENU:=$(LEDS_MENU)
+  TITLE:=PCengines WRAP LED support
+  DEPENDS:=@TARGET_x86 +kmod-gpio-scx200
+  KCONFIG:=CONFIG_LEDS_WRAP
+  FILES:=$(LINUX_DIR)/drivers/leds/leds-wrap.ko
+  AUTOLOAD:=$(call AutoLoad,50,leds-wrap)
+endef
+
+define KernelPackage/leds-wrap/description
+ Kernel module for PCengines WRAP LEDs
+endef
+
+$(eval $(call KernelPackage,leds-wrap))
+
+
+define KernelPackage/leds-net48xx
+  SUBMENU:=$(LEDS_MENU)
+  TITLE:=Soekris Net48xx LED support
+  DEPENDS:=@TARGET_x86 +kmod-gpio-scx200
+  KCONFIG:=CONFIG_LEDS_NET48XX
+  FILES:=$(LINUX_DIR)/drivers/leds/leds-net48xx.ko
+  AUTOLOAD:=$(call AutoLoad,50,leds-net48xx)
+endef
+
+define KernelPackage/leds-net48xx/description
+ Kernel module for Soekris Net48xx LEDs
+endef
+
+$(eval $(call KernelPackage,leds-net48xx))
+
+define KernelPackage/rdc321x-wdt
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=RDC321x watchdog
+  DEPENDS:=@TARGET_x86_rdc
+  KCONFIG:=CONFIG_RDC321X_WDT
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/rdc321x_wdt.ko
+  AUTOLOAD:=$(call AutoLoad,50,rdc321x_wdt)
+endef
+
+define KernelPackage/rdc321x-wdt/description
+  RDC-321x watchdog driver
+endef
+
+$(eval $(call KernelPackage,rdc321x-wdt))
+