rpcd: iwinfo plugin fixes
[openwrt.git] / target / linux / x86 / image / Makefile
index 8546020..8e56372 100644 (file)
@@ -100,38 +100,6 @@ endif
 
 ROOTDELAY=10
 
-ifneq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),)
-
-  define Image/cmdline/ext4
-    root=$(ROOTPART) rootfstype=ext4 rootwait
-  endef
-
-  define Image/cmdline/jffs2-64k
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootdelay=$(ROOTDELAY)
-  endef
-
-  define Image/cmdline/jffs2-128k
-    block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootdelay=$(ROOTDELAY)
-  endef
-
-  define Image/cmdline/squashfs
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootdelay=$(ROOTDELAY)
-  endef
-
-  define Image/Build/bootscript
-       # left here because the image builder doesnt need these
-       $(INSTALL_DIR) $(KDIR)/root.bootscript/boot
-       $(CP) $(KDIR)/bzImage $(KDIR)/root.bootscript/boot/vmlinuz
-       sed -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(BOOTOPTS)#g' \
-               ./olpc.fth > $(KDIR)/root.bootscript/boot/olpc.fth
-       PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_olpc.sh \
-               $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
-               $(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.bootscript \
-               $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
-  endef
-
-endif
-
 define Image/Build/squashfs
        $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
 endef
@@ -181,8 +149,8 @@ ifneq ($(CONFIG_VMDK_IMAGES),)
 endif
 
 define Image/Build/gzip
-       gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img
-       gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
+       gzip -f9n $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img
+       gzip -f9n $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
 endef
 
 ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
@@ -238,8 +206,6 @@ define Image/Build/Profile/bifferboard
 endef
 
 define Image/Prepare
-       $(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
-       $(call Image/Prepare/bootscript)
        $(call Image/Prepare/grub2)
 endef
 
@@ -249,7 +215,6 @@ endef
 
 define Image/Build
        $(call Image/Build/$(1))
-       $(call Image/Build/bootscript,$(1))
   ifneq ($(1),iso)
        $(call Image/Build/grub2,$(1))
        $(call Image/Build/vdi,$(1))