[target] stay coherent when defining ARCH
[openwrt.git] / target / linux / x86 / Makefile
index 3288de3..9a1685d 100644 (file)
@@ -6,16 +6,15 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2 vdi
-SUBTARGETS=generic
+FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
+SUBTARGETS=generic olpc
 
-LINUX_VERSION:=2.6.25.16
+LINUX_VERSION:=2.6.31.7
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
 $(eval $(call BuildTarget))