kernel/base-files: clean up old code related to refreshing mtd partitions, it is...
[openwrt.git] / target / linux / x86 / Makefile
index 197da8b..0d4fe47 100644 (file)
@@ -1,18 +1,21 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
-SUBTARGETS=generic
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
+SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan \
+          rdc
 
-LINUX_VERSION:=2.6.31
+LINUX_VERSION:=3.3.8
+
+KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk