make target/linux/* directories self-contained, use the selected kernel version for...
[openwrt.git] / target / linux / x86-2.6 / Makefile
index 59f02b3..77912e6 100644 (file)
@@ -6,16 +6,14 @@
 #
 include $(TOPDIR)/rules.mk
 
+ARCH=i386
+BOARD:=x86
+BOARDNAME:=x86
+FEATURES:=pci usb atm pcmcia jffs2 ext2
+
 LINUX_VERSION:=2.6.17
 LINUX_RELEASE:=1
 LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
-include ./config
-include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/kernel-build.mk
-
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+$(eval $(call BuildKernel))