make squashfs overlay support more generic and integrate it for x86-2.6
[openwrt.git] / target / linux / x86-2.6 / Makefile
index 2a9ab2c..2b8e497 100644 (file)
@@ -1,25 +1,18 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.16.7
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=9682b2bd6e02f3087982d7c3f5ba824e
+ARCH=i386
+BOARD:=x86
+BOARDNAME:=x86
+FEATURES:=squashfs jffs2 ext2
 
-include ../rules.mk
-include ./config
+include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += kmod-natsemi
 
-include ../generic-$(KERNEL)/modules.mk
-include ../kernel.mk
+$(eval $(call BuildKernel))
 
-
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
-
-$(LINUX_BUILD_DIR)/bzImage: $(LINUX_DIR)/vmlinux
-       $(MAKE) -C $(LINUX_DIR) V=1 CROSS_COMPILE=$(TARGET_CROSS) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) bzImage
-       $(CP) $(LINUX_DIR)/arch/i386/boot/bzImage $@
-       touch $@
-
-compile: $(LINUX_BUILD_DIR)/bzImage