realview: add 3.14 support
[openwrt.git] / target / linux / realview / Makefile
index ddc8d70..7081359 100644 (file)
@@ -9,10 +9,14 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=realview
 BOARDNAME:=ARM Ltd. Realview board (qemu)
-FEATURES:=squashfs jffs2 fpu
-CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
+FEATURES:=fpu ramdisk
+CPU_TYPE:=mpcore
+CPU_SUBTYPE:=vfp
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.37.4
+KERNEL_PATCHVER:=3.14
+
+DEVICE_TYPE:=developerboard
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -20,6 +24,6 @@ define Target/Description
        Build images for ARM Ltd. Realview boards to be run with qemu
 endef
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 $(eval $(call BuildTarget))