More rdc-2.6 fixes by Daniel Gimpelevich, thanks !
[openwrt.git] / target / linux / rdc-2.6 / Makefile
index bf096f2..1b180cd 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC x86
-FEATURES:=squashfs jffs2 broken
+FEATURES:=squashfs jffs2
 
 LINUX_VERSION:=2.6.22.1
 
@@ -22,10 +22,12 @@ include $(INCLUDE_DIR)/kernel-build.mk
 
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
     define Kernel/SetInitramfs
+       echo "r6040 parent=wlan0" > $(BUILD_DIR)/root/etc/modules.d/99-r6040
        rm -f $(BUILD_DIR)/root/sbin/init
        ln -s /etc/preinit $(BUILD_DIR)/root/sbin/init
        sed -i 's,exec /sbin/init,exec /bin/busybox init,g' $(BUILD_DIR)/root/etc/preinit
        sed -i 's,/sbin/init,/bin/busybox init,g' $(BUILD_DIR)/root/init
+       sed -i 's,eth0,eth1,g' $(BUILD_DIR)/root/etc/config/network
     endef
 endif