ramips: fix various mistakes in subtargets *.mk profiles
[openwrt.git] / target / linux / ramips / rt305x / profiles / upvel.mk
index fa1c993..c5d60f5 100644 (file)
@@ -5,14 +5,27 @@
 # See /LICENSE for more information.
 #
 
-define Profile/UPVEL
+define Profile/UR-326N4G
+       NAME:=UPVEL UR-326N4G
+       PACKAGES:=\
+               kmod-usb-core kmod-usb-dwc2 \
+               kmod-ledtrig-usbdev
+endef
+
+define Profile/UR-326N4G/Description
+       Default package set compatible with URVEL router board.
+endef
+$(eval $(call Profile,UR-326N4G))
+
+
+define Profile/UR-336UN
        NAME:=UPVEL UR-336UN
        PACKAGES:=\
-               kmod-usb-core kmod-usb-rt305x-dwc_otg \
+               kmod-usb-core kmod-usb-dwc2 \
                kmod-ledtrig-usbdev
 endef
 
-define Profile/UPVEL/Description
+define Profile/UR-336UN/Description
        Default package set compatible with URVEL router board.
 endef
-$(eval $(call Profile,UPVEL))
+$(eval $(call Profile,UR-336UN))