kernel: update linux 3.8 to 3.8.12
[openwrt.git] / target / linux / ramips / patches-3.8 / 0128-MIPS-ralink-add-pinmux-driver.patch
index 4271712..f28115c 100644 (file)
@@ -16,10 +16,8 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  4 files changed, 81 insertions(+), 1 deletion(-)
  create mode 100644 arch/mips/ralink/pinmux.c
 
-Index: linux-3.8.11/arch/mips/ralink/Makefile
-===================================================================
---- linux-3.8.11.orig/arch/mips/ralink/Makefile        2013-05-03 17:53:16.612004798 +0200
-+++ linux-3.8.11/arch/mips/ralink/Makefile     2013-05-06 12:29:27.516615708 +0200
+--- a/arch/mips/ralink/Makefile
++++ b/arch/mips/ralink/Makefile
 @@ -6,7 +6,7 @@
  # Copyright (C) 2009-2011 Gabor Juhos <juhosg@openwrt.org>
  # Copyright (C) 2013 John Crispin <blogic@openwrt.org>
@@ -29,22 +27,18 @@ Index: linux-3.8.11/arch/mips/ralink/Makefile
  
  obj-$(CONFIG_SOC_RT288X) += rt288x.o
  obj-$(CONFIG_SOC_RT305X) += rt305x.o
-Index: linux-3.8.11/arch/mips/ralink/common.h
-===================================================================
---- linux-3.8.11.orig/arch/mips/ralink/common.h        2013-05-03 17:53:16.720004800 +0200
-+++ linux-3.8.11/arch/mips/ralink/common.h     2013-05-06 12:29:27.108615690 +0200
-@@ -50,4 +50,6 @@
+--- a/arch/mips/ralink/common.h
++++ b/arch/mips/ralink/common.h
+@@ -50,4 +50,6 @@ extern void prom_soc_init(struct ralink_
  
  __iomem void *plat_of_remap_node(const char *node);
  
 +void ralink_pinmux(void);
 +
  #endif /* _RALINK_COMMON_H__ */
-Index: linux-3.8.11/arch/mips/ralink/of.c
-===================================================================
---- linux-3.8.11.orig/arch/mips/ralink/of.c    2013-05-03 17:53:16.780004804 +0200
-+++ linux-3.8.11/arch/mips/ralink/of.c 2013-05-06 12:29:27.108615690 +0200
-@@ -110,6 +110,8 @@
+--- a/arch/mips/ralink/of.c
++++ b/arch/mips/ralink/of.c
+@@ -110,6 +110,8 @@ static int __init plat_of_setup(void)
        if (of_platform_populate(NULL, of_ids, NULL, NULL))
                panic("failed to populate DT\n");
  
@@ -53,10 +47,8 @@ Index: linux-3.8.11/arch/mips/ralink/of.c
        return 0;
  }
  
-Index: linux-3.8.11/arch/mips/ralink/pinmux.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.8.11/arch/mips/ralink/pinmux.c     2013-05-06 12:29:41.212616302 +0200
+--- /dev/null
++++ b/arch/mips/ralink/pinmux.c
 @@ -0,0 +1,77 @@
 +/*
 + *  This program is free software; you can redistribute it and/or modify it