kernel: refresh patches
[openwrt.git] / target / linux / ramips / patches-3.14 / 0047-GPIO-MIPS-ralink-add-gpio-driver-for-ralink-SoC.patch
index 239cd07..c3c5924 100644 (file)
@@ -18,10 +18,8 @@ Cc: linux-gpio@vger.kernel.org
  create mode 100644 arch/mips/include/asm/mach-ralink/gpio.h
  create mode 100644 drivers/gpio/gpio-ralink.c
 
-Index: linux-3.14.18/arch/mips/include/asm/mach-ralink/gpio.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.14.18/arch/mips/include/asm/mach-ralink/gpio.h     2014-09-13 02:13:22.536816660 +0200
+--- /dev/null
++++ b/arch/mips/include/asm/mach-ralink/gpio.h
 @@ -0,0 +1,24 @@
 +/*
 + *  Ralink SoC GPIO API support
@@ -47,11 +45,9 @@ Index: linux-3.14.18/arch/mips/include/asm/mach-ralink/gpio.h
 +#define gpio_to_irq   __gpio_to_irq
 +
 +#endif /* __ASM_MACH_RALINK_GPIO_H */
-Index: linux-3.14.18/drivers/gpio/Kconfig
-===================================================================
---- linux-3.14.18.orig/drivers/gpio/Kconfig    2014-09-06 01:34:59.000000000 +0200
-+++ linux-3.14.18/drivers/gpio/Kconfig 2014-10-02 21:52:28.693719524 +0200
-@@ -260,6 +260,12 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -260,6 +260,12 @@ config GPIO_SCH311X
          To compile this driver as a module, choose M here: the module will
          be called gpio-sch311x.
  
@@ -64,11 +60,9 @@ Index: linux-3.14.18/drivers/gpio/Kconfig
  config GPIO_SPEAR_SPICS
        bool "ST SPEAr13xx SPI Chip Select as GPIO support"
        depends on PLAT_SPEAR
-Index: linux-3.14.18/drivers/gpio/Makefile
-===================================================================
---- linux-3.14.18.orig/drivers/gpio/Makefile   2014-09-06 01:34:59.000000000 +0200
-+++ linux-3.14.18/drivers/gpio/Makefile        2014-10-02 21:52:28.693719524 +0200
-@@ -63,6 +63,7 @@
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -63,6 +63,7 @@ obj-$(CONFIG_GPIO_PCF857X)   += gpio-pcf85
  obj-$(CONFIG_GPIO_PCH)                += gpio-pch.o
  obj-$(CONFIG_GPIO_PL061)      += gpio-pl061.o
  obj-$(CONFIG_GPIO_PXA)                += gpio-pxa.o
@@ -76,10 +70,8 @@ Index: linux-3.14.18/drivers/gpio/Makefile
  obj-$(CONFIG_GPIO_RC5T583)    += gpio-rc5t583.o
  obj-$(CONFIG_GPIO_RDC321X)    += gpio-rdc321x.o
  obj-$(CONFIG_GPIO_RCAR)               += gpio-rcar.o
-Index: linux-3.14.18/drivers/gpio/gpio-ralink.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.14.18/drivers/gpio/gpio-ralink.c   2014-10-02 21:52:24.081719605 +0200
+--- /dev/null
++++ b/drivers/gpio/gpio-ralink.c
 @@ -0,0 +1,353 @@
 +/*
 + * This program is free software; you can redistribute it and/or modify it