ralink: add mt7621 support
[openwrt.git] / target / linux / ramips / patches-3.10 / 0202-owrt-USB-adds-dwc_otg.patch
index 65ed512..5c17a66 100644 (file)
@@ -49,9 +49,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/usb/Kconfig
 +++ b/drivers/usb/Kconfig
-@@ -126,6 +126,8 @@ source "drivers/usb/core/Kconfig"
+@@ -126,6 +126,8 @@ if USB
  
- source "drivers/usb/dwc3/Kconfig"
+ source "drivers/usb/core/Kconfig"
  
 +source "drivers/usb/dwc_otg/Kconfig"
 +
@@ -60,8 +60,8 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  source "drivers/usb/wusbcore/Kconfig"
 --- a/drivers/usb/Makefile
 +++ b/drivers/usb/Makefile
-@@ -9,6 +9,7 @@ obj-$(CONFIG_USB)              += core/
- obj-$(CONFIG_USB_OTG_UTILS)   += otg/
+@@ -7,6 +7,7 @@
+ obj-$(CONFIG_USB)             += core/
  
  obj-$(CONFIG_USB_DWC3)                += dwc3/
 +obj-$(CONFIG_DWC_OTG)         += dwc_otg/
@@ -9084,7 +9084,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 +      /*
 +       * Create Device Attributes in sysfs
 +       */
-+      dwc_otg_attr_create(&pdev->dev);
++      //dwc_otg_attr_create(&pdev->dev);
 +
 +      /*
 +       * Disable the global interrupt until all the interrupt