kernel: update 3.10 to 3.10.2
[openwrt.git] / target / linux / ramips / patches-3.10 / 0025-watchdog-adds-ralink-wdt.patch
index 63e54c6..dd69d57 100644 (file)
@@ -14,8 +14,6 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  4 files changed, 216 insertions(+)
  create mode 100644 drivers/watchdog/rt2880_wdt.c
 
-diff --git a/arch/mips/ralink/mt7620.c b/arch/mips/ralink/mt7620.c
-index 6f6b1c8..14c28b0 100644
 --- a/arch/mips/ralink/mt7620.c
 +++ b/arch/mips/ralink/mt7620.c
 @@ -182,6 +182,7 @@ void __init ralink_clk_init(void)
@@ -26,8 +24,6 @@ index 6f6b1c8..14c28b0 100644
        ralink_clk_add("10000500.uart", 40000000);
        ralink_clk_add("10000b00.spi", 40000000);
        ralink_clk_add("10000c00.uartlite", 40000000);
-diff --git a/drivers/watchdog/Kconfig b/drivers/watchdog/Kconfig
-index e89fc31..5e34760 100644
 --- a/drivers/watchdog/Kconfig
 +++ b/drivers/watchdog/Kconfig
 @@ -1104,6 +1104,13 @@ config LANTIQ_WDT
@@ -44,8 +40,6 @@ index e89fc31..5e34760 100644
  # PARISC Architecture
  
  # POWERPC Architecture
-diff --git a/drivers/watchdog/Makefile b/drivers/watchdog/Makefile
-index a300b94..2681e3d 100644
 --- a/drivers/watchdog/Makefile
 +++ b/drivers/watchdog/Makefile
 @@ -134,6 +134,7 @@ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
@@ -56,9 +50,6 @@ index a300b94..2681e3d 100644
  
  # PARISC Architecture
  
-diff --git a/drivers/watchdog/rt2880_wdt.c b/drivers/watchdog/rt2880_wdt.c
-new file mode 100644
-index 0000000..ebba535
 --- /dev/null
 +++ b/drivers/watchdog/rt2880_wdt.c
 @@ -0,0 +1,207 @@
@@ -269,6 +260,3 @@ index 0000000..ebba535
 +MODULE_AUTHOR("Gabor Juhos <juhosg@openwrt.org");
 +MODULE_LICENSE("GPL v2");
 +MODULE_ALIAS_MISCDEV(WATCHDOG_MINOR);
--- 
-1.7.10.4
-