base-files: allow users to delect debug level during boot
[openwrt.git] / target / linux / ramips / modules.mk
index 179aba6..adf5e02 100644 (file)
@@ -19,12 +19,26 @@ define KernelPackage/usb-rt305x-dwc_otg
 endef
 
 define KernelPackage/usb-rt305x-dwc_otg/description
 This driver provides USB Device Controller support for the
 Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
+ This driver provides USB Device Controller support for the
+ Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
 endef
 
 $(eval $(call KernelPackage,usb-rt305x-dwc_otg))
 
+OTHER_MENU:=Other modules
+define KernelPackage/sdhci-mt7620
+  SUBMENU:=Other modules
+  TITLE:=MT7620 SDCI
+  DEPENDS:=@TARGET_ramips_mt7620a +kmod-sdhci
+  KCONFIG:= \
+       CONFIG_MMC_SDHCI_MT7620
+  FILES:= \
+       $(LINUX_DIR)/drivers/mmc/host/sdhci-mt7620.ko
+  AUTOLOAD:=$(call AutoProbe,sdhci-mt7620,1)
+endef
+
+$(eval $(call KernelPackage,sdhci-mt7620))
+
 I2C_RALINK_MODULES:= \
   CONFIG_I2C_RALINK:drivers/i2c/busses/i2c-ralink