ramips: add additional support for MQmaker WiTi board
[openwrt.git] / target / linux / ramips / image / Makefile
index 9521f2c..63d6222 100644 (file)
@@ -39,7 +39,7 @@ define Device/Default
 endef
 
 define Build/patch-dtb
-       $(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $@.dtb ../dts/$(DTS).dts
+       $(call Image/BuildDTB,../dts/$(DTS).dts,$@.dtb)
        $(STAGING_DIR_HOST)/bin/patch-dtb $@ $@.dtb
 endef
 
@@ -708,7 +708,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/3G6200NL,$(1))
        $(call Image/Build/Profile/3G150B,$(1))
        $(call Image/Build/Profile/3G300M,$(1))
-       $(call Image/Build/Profile/A5-11,$(1))
+       $(call Image/Build/Profile/A5-V11,$(1))
        $(call Image/Build/Profile/AIR3GII,$(1))
        $(call Image/Build/Profile/ALL02393G,$(1))
        $(call Image/Build/Profile/ALL0256N,$(1))
@@ -954,7 +954,7 @@ endif
 #
 
 ifeq ($(SUBTARGET),mt7621)
-  TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 zbt-wg2626 wf-2881
+  TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 witi wf-2881 zbt-wg2626
 endif
 
 define Device/mt7621
@@ -1004,6 +1004,11 @@ define Device/sap-g3200u3
   DTS := SAP-G3200U3
 endef
 
+define Device/witi
+  DTS := WITI
+  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+endef
+
 define Device/zbt-wg2626
   DTS := ZBT-WG2626
   IMAGE_SIZE := $(ralink_default_fw_size_16M)