ramips: rt305x: add kernel support for the Planex MZK-W300NH2 Router
[openwrt.git] / target / linux / ramips / files / arch / mips / ralink / rt305x / Makefile
index bb8cf07..8fa7535 100644 (file)
@@ -14,11 +14,18 @@ obj-$(CONFIG_EARLY_PRINTK)          += early_printk.o
 obj-$(CONFIG_RT305X_MACH_3G_6200N)     += mach-3g-6200n.o
 obj-$(CONFIG_RT305X_MACH_ARGUS_ATP52B) += mach-argus-atp52b.o
 obj-$(CONFIG_RT305X_MACH_BC2)          += mach-bc2.o
+obj-$(CONFIG_RT305X_MACH_AIR3GII)      += mach-air3gii.o
 obj-$(CONFIG_RT305X_MACH_ALL0256N)     += mach-all0256n.o
+obj-$(CONFIG_RT305X_MACH_ALL5002)      += mach-all5002.o
+obj-$(CONFIG_RT305X_MACH_BROADWAY)     += mach-broadway.o
+obj-$(CONFIG_RT305X_MACH_CARAMBOLA)    += mach-carambola.o
 obj-$(CONFIG_RT305X_MACH_DIR_300_REVB) += mach-dir-300-revb.o
+obj-$(CONFIG_RT305X_MACH_DIR_615_H1)   += mach-dir-615-h1.o
+obj-$(CONFIG_RT305X_MACH_DAP_1350)     += mach-dap-1350.o
 obj-$(CONFIG_RT305X_MACH_ESR_9753)     += mach-esr-9753.o
 obj-$(CONFIG_RT305X_MACH_F5D8235_V2)    += mach-f5d8235-v2.o
 obj-$(CONFIG_RT305X_MACH_FONERA20N)    += mach-fonera20n.o
+obj-$(CONFIG_RT305X_MACH_RT_N13U)      += mach-rt-n13u.o
 obj-$(CONFIG_RT305X_MACH_FREESTATION5)  += mach-freestation5.o
 obj-$(CONFIG_RT305X_MACH_HW550_3G)     += mach-hw550-3g.o
 obj-$(CONFIG_RT305X_MACH_MOFI3500_3GN) += mach-mofi3500-3gn.o
@@ -42,4 +49,5 @@ obj-$(CONFIG_RT305X_MACH_WL_330N3G)   += mach-wl-330n3g.o
 obj-$(CONFIG_RT305X_MACH_WL341V3)      += mach-wl341v3.o
 obj-$(CONFIG_RT305X_MACH_WL351)                += mach-wl351.o
 obj-$(CONFIG_RT305X_MACH_WR6202)       += mach-wr6202.o
+obj-$(CONFIG_RT305X_MACH_MZKW300NH2)   += mach-mzk-w300nh2.o
 obj-$(CONFIG_RT305X_MACH_XDX_RN502J)    += mach-xdx-rn502j.o