define a shared IMG_PREFIX variable used as a basename for image files, it contains...
[openwrt.git] / target / linux / pxcab / image / Makefile
index ae551fa..b2e08f0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -13,8 +13,8 @@ endef
 
 define Image/BuildKernel
        mkdir -p $(BIN_DIR)
-       cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
-       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+       cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
 endef
 
 $(eval $(call BuildImage))