kernel: define RB_ID_HW_OPTIONS in include/linux/routerboot.h
[openwrt.git] / target / linux / ppc40x / modules.mk
index 8859a27..4db39fa 100644 (file)
@@ -20,3 +20,22 @@ define KernelPackage/ata-magicbox-cf/description
 endef
 
 $(eval $(call KernelPackage,ata-magicbox-cf))
+
+
+define KernelPackage/usb-isp116x-hcd
+  TITLE:=Support for the ISP116x USB Host Controller
+  DEPENDS:=@TARGET_ppc40x
+  KCONFIG:= \
+       CONFIG_USB_ISP116X_HCD \
+       CONFIG_USB_ISP116X_HCD_OF=y \
+       CONFIG_USB_ISP116X_HCD_PLATFORM=n
+  FILES:=$(LINUX_DIR)/drivers/usb/host/isp116x-hcd.ko
+  AUTOLOAD:=$(call AutoLoad,50,isp116x-hcd)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-isp116x-hcd/description
+  Kernel support for the ISP116X USB Host Controller
+endef
+
+$(eval $(call KernelPackage,usb-isp116x-hcd))