Revert "ar71xx: Clear bits in ath79_setup_qca955x_eth_cfg"
[openwrt.git] / target / linux / mcs814x / Makefile
index a62b6e5..af1548f 100644 (file)
@@ -9,11 +9,13 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=mcs814x
 BOARDNAME:=Moschip MCS814x
-FEATURES:=pci usb
-CFLAGS=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+FEATURES:=usb squashfs low_mem
+CPU_TYPE:=arm926ej-s
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=3.18
+
+DEVICE_TYPE:=other
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -24,6 +26,6 @@ DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES)) \
                  kmod-nls-utf8 \
                  kmod-mcs814x-wdt kmod-ledtrig-usbdev
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 $(eval $(call BuildTarget))