lantiq: add wifi eep to a803 dts file
[openwrt.git] / target / linux / lantiq / patches-3.9 / 0006-SPI-MIPS-lantiq-adds-spi-xway.patch
index 008f6ab..1c32947 100644 (file)
@@ -16,11 +16,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  3 files changed, 986 insertions(+)
  create mode 100644 drivers/spi/spi-xway.c
 
-diff --git a/drivers/spi/Kconfig b/drivers/spi/Kconfig
-index 2be0de9..2c8cd63 100644
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -461,6 +461,14 @@ config SPI_NUC900
+@@ -470,6 +470,14 @@ config SPI_NUC900
        help
          SPI driver for Nuvoton NUC900 series ARM SoCs
  
@@ -35,18 +33,13 @@ index 2be0de9..2c8cd63 100644
  #
  # Add new SPI master controllers in alphabetical order above this line
  #
-diff --git a/drivers/spi/Makefile b/drivers/spi/Makefile
-index e53c309..f65578d 100644
 --- a/drivers/spi/Makefile
 +++ b/drivers/spi/Makefile
-@@ -71,3 +71,4 @@ obj-$(CONFIG_SPI_TOPCLIFF_PCH)               += spi-topcliff-pch.o
+@@ -72,3 +72,4 @@ obj-$(CONFIG_SPI_TOPCLIFF_PCH)               += spi-t
  obj-$(CONFIG_SPI_TXX9)                        += spi-txx9.o
  obj-$(CONFIG_SPI_XCOMM)               += spi-xcomm.o
  obj-$(CONFIG_SPI_XILINX)              += spi-xilinx.o
 +obj-$(CONFIG_SPI_XWAY)                        += spi-xway.o
-diff --git a/drivers/spi/spi-xway.c b/drivers/spi/spi-xway.c
-new file mode 100644
-index 0000000..61532e3
 --- /dev/null
 +++ b/drivers/spi/spi-xway.c
 @@ -0,0 +1,977 @@
@@ -1027,6 +1020,3 @@ index 0000000..61532e3
 +MODULE_AUTHOR("Daniel Schwierzeck <daniel.schwierzeck@googlemail.com>");
 +MODULE_LICENSE("GPL");
 +MODULE_ALIAS("platform:spi-xway");
--- 
-1.7.10.4
-