kernel: update linux 3.2 to 3.2.15
[openwrt.git] / target / linux / lantiq / patches-3.2 / 0005-MIPS-lantiq-reorganize-xway-code.patch
index 59353d9..a279ebd 100644 (file)
@@ -38,8 +38,6 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  delete mode 100644 arch/mips/lantiq/xway/setup-xway.c
  create mode 100644 arch/mips/lantiq/xway/sysctrl.c
 
-diff --git a/arch/mips/include/asm/mach-lantiq/lantiq.h b/arch/mips/include/asm/mach-lantiq/lantiq.h
-index ce2f029..66d7300 100644
 --- a/arch/mips/include/asm/mach-lantiq/lantiq.h
 +++ b/arch/mips/include/asm/mach-lantiq/lantiq.h
 @@ -9,6 +9,7 @@
@@ -66,7 +64,7 @@ index ce2f029..66d7300 100644
  extern unsigned int ltq_get_cpu_ver(void);
  extern unsigned int ltq_get_soc_type(void);
  
-@@ -51,7 +43,9 @@ extern void ltq_enable_irq(struct irq_data *data);
+@@ -51,7 +43,9 @@ extern void ltq_enable_irq(struct irq_da
  
  /* find out what caused the last cpu reset */
  extern int ltq_reset_cause(void);
@@ -77,8 +75,6 @@ index ce2f029..66d7300 100644
  
  #define IOPORT_RESOURCE_START 0x10000000
  #define IOPORT_RESOURCE_END   0xffffffff
-diff --git a/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h b/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
-index 8a3c6be..9b7ee366 100644
 --- a/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
 +++ b/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
 @@ -61,6 +61,8 @@
@@ -121,8 +117,6 @@ index 8a3c6be..9b7ee366 100644
  
  static inline int ltq_is_ar9(void)
  {
-diff --git a/arch/mips/lantiq/clk.c b/arch/mips/lantiq/clk.c
-index 77ed70f..39eef7f 100644
 --- a/arch/mips/lantiq/clk.c
 +++ b/arch/mips/lantiq/clk.c
 @@ -22,6 +22,7 @@
@@ -156,12 +150,12 @@ index 77ed70f..39eef7f 100644
  
 -      if (insert_resource(&iomem_resource, &ltq_cgu_resource) < 0)
 -              panic("Failed to insert cgu memory\n");
--
++      ltq_soc_init();
 -      if (request_mem_region(ltq_cgu_resource.start,
 -                      resource_size(&ltq_cgu_resource), "cgu") < 0)
 -              panic("Failed to request cgu memory\n");
-+      ltq_soc_init();
+-
 -      ltq_cgu_membase = ioremap_nocache(ltq_cgu_resource.start,
 -                              resource_size(&ltq_cgu_resource));
 -      if (!ltq_cgu_membase) {
@@ -174,8 +168,6 @@ index 77ed70f..39eef7f 100644
 +      pr_info("CPU Clock: %ldMHz\n", clk_get_rate(clk) / 1000000);
        clk_put(clk);
  }
-diff --git a/arch/mips/lantiq/devices.c b/arch/mips/lantiq/devices.c
-index de1cb2b..7193d78 100644
 --- a/arch/mips/lantiq/devices.c
 +++ b/arch/mips/lantiq/devices.c
 @@ -27,12 +27,8 @@
@@ -193,7 +185,7 @@ index de1cb2b..7193d78 100644
  
  static struct platform_device ltq_nor = {
        .name           = "ltq_nor",
-@@ -47,12 +43,8 @@ void __init ltq_register_nor(struct physmap_flash_data *data)
+@@ -47,12 +43,8 @@ void __init ltq_register_nor(struct phys
  }
  
  /* watchdog */
@@ -235,8 +227,6 @@ index de1cb2b..7193d78 100644
        IRQ_RES(tx, LTQ_ASC_TIR(1)),
        IRQ_RES(rx, LTQ_ASC_RIR(1)),
        IRQ_RES(err, LTQ_ASC_EIR(1)),
-diff --git a/arch/mips/lantiq/devices.h b/arch/mips/lantiq/devices.h
-index 2947bb1..a03c23f 100644
 --- a/arch/mips/lantiq/devices.h
 +++ b/arch/mips/lantiq/devices.h
 @@ -14,6 +14,10 @@
@@ -250,8 +240,6 @@ index 2947bb1..a03c23f 100644
  
  extern void ltq_register_nor(struct physmap_flash_data *data);
  extern void ltq_register_wdt(void);
-diff --git a/arch/mips/lantiq/prom.c b/arch/mips/lantiq/prom.c
-index e34fcfd..e3b1e25 100644
 --- a/arch/mips/lantiq/prom.c
 +++ b/arch/mips/lantiq/prom.c
 @@ -16,6 +16,10 @@
@@ -265,7 +253,7 @@ index e34fcfd..e3b1e25 100644
  static struct ltq_soc_info soc_info;
  
  unsigned int ltq_get_cpu_ver(void)
-@@ -55,16 +59,51 @@ static void __init prom_init_cmdline(void)
+@@ -55,16 +59,51 @@ static void __init prom_init_cmdline(voi
        }
  }
  
@@ -275,7 +263,7 @@ index e34fcfd..e3b1e25 100644
 -      struct clk *clk;
 +      __iomem void *ret = NULL;
 +      struct resource *lookup = lookup_resource(&iomem_resource, res->start);
-+
 +      if (lookup && strcmp(lookup->name, res->name)) {
 +              pr_err("conflicting memory range %s\n", res->name);
 +              return NULL;
@@ -291,7 +279,7 @@ index e34fcfd..e3b1e25 100644
 +              pr_err("Failed to request %s memory\n", res->name);
 +              goto err_res;
 +      }
++
 +      ret = ioremap_nocache(res->start, resource_size(res));
 +      if (!ret)
 +              goto err_mem;
@@ -323,8 +311,6 @@ index e34fcfd..e3b1e25 100644
        soc_info.sys_type[LTQ_SYS_TYPE_LEN - 1] = '\0';
        pr_info("SoC: %s\n", soc_info.sys_type);
        prom_init_cmdline();
-diff --git a/arch/mips/lantiq/prom.h b/arch/mips/lantiq/prom.h
-index b4229d9..51dba1b 100644
 --- a/arch/mips/lantiq/prom.h
 +++ b/arch/mips/lantiq/prom.h
 @@ -9,17 +9,21 @@
@@ -349,8 +335,6 @@ index b4229d9..51dba1b 100644
  extern void ltq_soc_setup(void);
  
  #endif
-diff --git a/arch/mips/lantiq/xway/Makefile b/arch/mips/lantiq/xway/Makefile
-index c517f2e..6678402 100644
 --- a/arch/mips/lantiq/xway/Makefile
 +++ b/arch/mips/lantiq/xway/Makefile
 @@ -1,7 +1,7 @@
@@ -364,8 +348,6 @@ index c517f2e..6678402 100644
  
  obj-$(CONFIG_LANTIQ_MACH_EASY50712) += mach-easy50712.o
  obj-$(CONFIG_LANTIQ_MACH_EASY50601) += mach-easy50601.o
-diff --git a/arch/mips/lantiq/xway/devices.c b/arch/mips/lantiq/xway/devices.c
-index d614aa7..f97e565 100644
 --- a/arch/mips/lantiq/xway/devices.c
 +++ b/arch/mips/lantiq/xway/devices.c
 @@ -31,22 +31,9 @@
@@ -438,8 +420,6 @@ index d614aa7..f97e565 100644
  
  static struct platform_device ltq_etop = {
        .name           = "ltq_etop",
-diff --git a/arch/mips/lantiq/xway/dma.c b/arch/mips/lantiq/xway/dma.c
-index cbb6ae5..60cd11f 100644
 --- a/arch/mips/lantiq/xway/dma.c
 +++ b/arch/mips/lantiq/xway/dma.c
 @@ -24,6 +24,8 @@
@@ -485,9 +465,6 @@ index cbb6ae5..60cd11f 100644
        if (!ltq_dma_membase)
                panic("Failed to remap dma memory\n");
  
-diff --git a/arch/mips/lantiq/xway/ebu.c b/arch/mips/lantiq/xway/ebu.c
-deleted file mode 100644
-index 033b318..0000000
 --- a/arch/mips/lantiq/xway/ebu.c
 +++ /dev/null
 @@ -1,52 +0,0 @@
@@ -543,9 +520,6 @@ index 033b318..0000000
 -}
 -
 -postcore_initcall(lantiq_ebu_init);
-diff --git a/arch/mips/lantiq/xway/pmu.c b/arch/mips/lantiq/xway/pmu.c
-deleted file mode 100644
-index 39f0d26..0000000
 --- a/arch/mips/lantiq/xway/pmu.c
 +++ /dev/null
 @@ -1,69 +0,0 @@
@@ -618,8 +592,6 @@ index 39f0d26..0000000
 -}
 -
 -core_initcall(ltq_pmu_init);
-diff --git a/arch/mips/lantiq/xway/prom-ase.c b/arch/mips/lantiq/xway/prom-ase.c
-index ae4959a..3f86a3b 100644
 --- a/arch/mips/lantiq/xway/prom-ase.c
 +++ b/arch/mips/lantiq/xway/prom-ase.c
 @@ -13,6 +13,7 @@
@@ -630,7 +602,7 @@ index ae4959a..3f86a3b 100644
  #include "../prom.h"
  
  #define SOC_AMAZON_SE "Amazon_SE"
-@@ -26,6 +27,7 @@ void __init ltq_soc_detect(struct ltq_soc_info *i)
+@@ -26,6 +27,7 @@ void __init ltq_soc_detect(struct ltq_so
  {
        i->partnum = (ltq_r32(LTQ_MPS_CHIPID) & PART_MASK) >> PART_SHIFT;
        i->rev = (ltq_r32(LTQ_MPS_CHIPID) & REV_MASK) >> REV_SHIFT;
@@ -638,7 +610,7 @@ index ae4959a..3f86a3b 100644
        switch (i->partnum) {
        case SOC_ID_AMAZON_SE:
                i->name = SOC_AMAZON_SE;
-@@ -37,3 +39,10 @@ void __init ltq_soc_detect(struct ltq_soc_info *i)
+@@ -37,3 +39,10 @@ void __init ltq_soc_detect(struct ltq_so
                break;
        }
  }
@@ -649,8 +621,6 @@ index ae4959a..3f86a3b 100644
 +      ltq_register_gpio();
 +      ltq_register_wdt();
 +}
-diff --git a/arch/mips/lantiq/xway/prom-xway.c b/arch/mips/lantiq/xway/prom-xway.c
-index 2228133..d823a92 100644
 --- a/arch/mips/lantiq/xway/prom-xway.c
 +++ b/arch/mips/lantiq/xway/prom-xway.c
 @@ -13,6 +13,7 @@
@@ -661,7 +631,7 @@ index 2228133..d823a92 100644
  #include "../prom.h"
  
  #define SOC_DANUBE    "Danube"
-@@ -28,6 +29,7 @@ void __init ltq_soc_detect(struct ltq_soc_info *i)
+@@ -28,6 +29,7 @@ void __init ltq_soc_detect(struct ltq_so
  {
        i->partnum = (ltq_r32(LTQ_MPS_CHIPID) & PART_MASK) >> PART_SHIFT;
        i->rev = (ltq_r32(LTQ_MPS_CHIPID) & REV_MASK) >> REV_SHIFT;
@@ -669,7 +639,7 @@ index 2228133..d823a92 100644
        switch (i->partnum) {
        case SOC_ID_DANUBE1:
        case SOC_ID_DANUBE2:
-@@ -52,3 +54,11 @@ void __init ltq_soc_detect(struct ltq_soc_info *i)
+@@ -52,3 +54,11 @@ void __init ltq_soc_detect(struct ltq_so
                break;
        }
  }
@@ -681,8 +651,6 @@ index 2228133..d823a92 100644
 +      ltq_register_gpio();
 +      ltq_register_wdt();
 +}
-diff --git a/arch/mips/lantiq/xway/reset.c b/arch/mips/lantiq/xway/reset.c
-index 3d41f0b..ca2212a 100644
 --- a/arch/mips/lantiq/xway/reset.c
 +++ b/arch/mips/lantiq/xway/reset.c
 @@ -15,6 +15,8 @@
@@ -728,9 +696,6 @@ index 3d41f0b..ca2212a 100644
        if (!ltq_rcu_membase)
                panic("Failed to remap rcu memory\n");
  
-diff --git a/arch/mips/lantiq/xway/setup-ase.c b/arch/mips/lantiq/xway/setup-ase.c
-deleted file mode 100644
-index f6f3267..0000000
 --- a/arch/mips/lantiq/xway/setup-ase.c
 +++ /dev/null
 @@ -1,19 +0,0 @@
@@ -753,9 +718,6 @@ index f6f3267..0000000
 -      ltq_register_gpio();
 -      ltq_register_wdt();
 -}
-diff --git a/arch/mips/lantiq/xway/setup-xway.c b/arch/mips/lantiq/xway/setup-xway.c
-deleted file mode 100644
-index c292f64..0000000
 --- a/arch/mips/lantiq/xway/setup-xway.c
 +++ /dev/null
 @@ -1,20 +0,0 @@
@@ -779,9 +741,6 @@ index c292f64..0000000
 -      ltq_register_gpio();
 -      ltq_register_wdt();
 -}
-diff --git a/arch/mips/lantiq/xway/sysctrl.c b/arch/mips/lantiq/xway/sysctrl.c
-new file mode 100644
-index 0000000..8fd13a1
 --- /dev/null
 +++ b/arch/mips/lantiq/xway/sysctrl.c
 @@ -0,0 +1,78 @@
@@ -863,8 +822,6 @@ index 0000000..8fd13a1
 +      /* make sure to unprotect the memory region where flash is located */
 +      ltq_ebu_w32(ltq_ebu_r32(LTQ_EBU_BUSCON0) & ~EBU_WRDIS, LTQ_EBU_BUSCON0);
 +}
-diff --git a/drivers/watchdog/lantiq_wdt.c b/drivers/watchdog/lantiq_wdt.c
-index 102aed0..179bf98 100644
 --- a/drivers/watchdog/lantiq_wdt.c
 +++ b/drivers/watchdog/lantiq_wdt.c
 @@ -16,7 +16,7 @@
@@ -876,6 +833,3 @@ index 102aed0..179bf98 100644
  
  /* Section 3.4 of the datasheet
   * The password sequence protects the WDT control register from unintended
--- 
-1.7.9.1
-