lantiq: fix vr9 ubi handling
[openwrt.git] / target / linux / lantiq / Makefile
index 10d6665..d7f7568 100644 (file)
@@ -6,15 +6,14 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-DEFAULT_SUBTARGET:=danube
+BOARDNAME:=Lantiq GPON/XWAY/SVIP
+FEATURES:=squashfs ubifs
+SUBTARGETS=xway xrx200 ase falcon
 
-LINUX_VERSION:=3.2.12
+LINUX_VERSION:=3.10.34
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC