rpcd: iwinfo plugin fixes
[openwrt.git] / target / linux / kirkwood / profiles / 115-router.mk
index f639451..7983755 100644 (file)
@@ -5,34 +5,28 @@
 # See /LICENSE for more information.
 #
 
-define Profile/EA3500
-  NAME:=Linksys EA3500
+define Profile/AUDI
+  NAME:=Linksys EA3500 (Audi)
   PACKAGES:= \
        kmod-mwl8k kmod-usb2 kmod-usb-storage \
-       uboot-envtools
+       swconfig wpad-mini
 endef
 
-define Profile/EA3500/Description
+define Profile/AUDI/Description
  Package set compatible with Linksys EA3500 board.
 endef
 
-EA3500_UBIFS_OPTS:="-m 512 -e 15872 -c 4096"
-EA3500_UBI_OPTS:="-m 512 -p 16384 -s 256"
+$(eval $(call Profile,AUDI))
 
-$(eval $(call Profile,EA3500))
-
-define Profile/EA4500
-  NAME:=Linksys EA4500
+define Profile/VIPER
+  NAME:=Linksys E4200v2 / EA4500 (Viper)
   PACKAGES:= \
        kmod-mwl8k kmod-usb2 kmod-usb-storage \
-       swconfig uboot-envtools
+       swconfig wpad-mini
 endef
 
-define Profile/EA4500/Description
- Package set compatible with Linksys EA4500 board.
+define Profile/VIPER/Description
+ Package set compatible with Linksys E4200v2 and EA4500 boards.
 endef
 
-EA4500_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
-EA4500_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
-
-$(eval $(call Profile,EA4500))
+$(eval $(call Profile,VIPER))