targets: prepare for supporting normal and initramfs images
[openwrt.git] / target / linux / ixp4xx / image / Makefile
index 167bd1d..564cafc 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,79 +7,65 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-UCODEFILE:=IPL_ixp400NpeLibrary-2_4.zip
-
-ifneq ($(CONFIG_IXP4XX_INCLUDE_UCODE),)
-  define Require/npe-ucode
-       [ -f $(DL_DIR)/$(UCODEFILE) ]
-  endef
-  define Build/Compile/npe
-       $(MAKE) -C npe-ucode \
-               BUILD_DIR="$(KDIR)" \
-               TARGET="$(KDIR)" \
-               compile
-  endef
-  define Image/Build/slug
+ifdef CONFIG_PACKAGE_apex
+  define Image/Build/Linksys
        BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
-               -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
-               -k $(BIN_DIR)/openwrt-nslu2-zImage \
-               -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
-               -p -o $(BIN_DIR)/openwrt-nslu2-$(1).bin
+               -L $(BIN_DIR)/apex/apex-$(2)-armeb.bin \
+               -k $(BIN_DIR)/openwrt-$(2)-zImage \
+               -r rootfs:$(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
+               -p -o $(BIN_DIR)/openwrt-$(2)-$(1).bin
        BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
-               -F -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
-               -k $(BIN_DIR)/openwrt-nslu2-zImage \
-               -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
-               -p -o $(BIN_DIR)/openwrt-nslu2-$(1)-16mb.bin
+               -F -L $(BIN_DIR)/apex/apex-$(2)-16mb-armeb.bin \
+               -k $(BIN_DIR)/openwrt-$(2)-zImage \
+               -r rootfs:$(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
+               -p -o $(BIN_DIR)/openwrt-$(2)-$(1)-16mb.bin
   endef
 endif
 
-define Build/Compile
-       $(MAKE) -C apex \
-               BUILD_DIR="$(KDIR)" \
-               TARGET="$(KDIR)" \
-               compile 
-       $(call Build/Compile/npe)
-endef
-
-define Build/Clean
-       $(MAKE) -C apex clean
-       $(MAKE) -C npe-ucode clean
+define Image/Build/Freecom
+       $(INSTALL_DIR) $(TARGET_DIR)/boot
+       # TODO: Add special CMDLINE shim for webupgrade image here
+       $(CP) $(BIN_DIR)/openwrt-$(2)-zImage $(TARGET_DIR)/zImage
+       $(TAR) cfj $(BIN_DIR)/openwrt-$(2)-$(1).img --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
+       $(STAGING_DIR_HOST)/bin/encode_crc $(BIN_DIR)/openwrt-$(2)-$(1).img $(BIN_DIR)/openwrt-$(2)-$(1)-webupgrade.img
+       rm -f $(TARGET_DIR)/zImage
 endef
 
-define Image/Prepare
-       cp $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/zImage
+define Image/BuildKernel
+       cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+       BIN_DIR=$(BIN_DIR) IMG_PREFIX="$(IMG_PREFIX)" $(TOPDIR)/scripts/arm-magic.sh
 endef
 
-define Image/BuildKernel
-       cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
-#      $(shell BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh)
-       BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
+# Build sysupgrade image
+define BuildFirmware/Generic
+       dd if=$(KDIR)/zImage of=$(KDIR)/zImage.pad bs=64k conv=sync; \
+       dd if=$(KDIR)/root.$(1) of=$(KDIR)/root.$(1).pad bs=128k conv=sync; \
+       sh $(TOPDIR)/scripts/combined-image.sh \
+               $(KDIR)/zImage.pad \
+               $(KDIR)/root.$(1).pad \
+               $(BIN_DIR)/$(IMG_PREFIX)-$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))-sysupgrade.bin
 endef
 
 define Image/Build
        $(call Image/Build/$(1),$(1))
+       $(call BuildFirmware/Generic,$(1))
 endef
 
 define Image/Build/jffs2-64k
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=65536 conv=sync
 endef
 
 define Image/Build/jffs2-128k
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
-       $(call Image/Build/slug,$(1))
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=131072 conv=sync
+       $(call Image/Build/Linksys,$(1),nslu2,$(1))
+       $(call Image/Build/Freecom,$(1),fsg3,$(1))
 endef
 
 define Image/Build/squashfs
-    $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
-       $(call Image/Build/slug,$(1))
+       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=131072 conv=sync
+       $(call Image/Build/Linksys,$(1),nslu2,$(1))
+       $(call Image/Build/Freecom,$(1),fsg3,$(1))
 endef
 
 $(eval $(call BuildImage))
-
-$(eval $(call Require,npe-ucode, \
-       You must manually download $(UCODEFILE) from \\\
-       http://www.intel.com/design/network/products/npfamily/ixp400_archives.htm \\\
-       and put it in $(DL_DIR). \\\
-       You will need to agree to the Intel Public License to do so - please do read it! \
-))