linux/3.2: build mdio_register_board_info into the kernel if PHYLIB is selected
[openwrt.git] / target / linux / generic / patches-3.2 / 723-phy_ip175c.patch
index 0ac339e..05b9619 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -112,6 +112,10 @@ config ADM6996_PHY
+@@ -116,6 +116,10 @@ config ADM6996_PHY
  config MVSWITCH_PHY
        tristate "Driver for Marvell 88E6060 switches"
  
@@ -13,7 +13,7 @@
        depends on PHYLIB=y
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -16,6 +16,7 @@ obj-$(CONFIG_BCM63XX_PHY)    += bcm63xx.o
+@@ -18,6 +18,7 @@ obj-$(CONFIG_BCM63XX_PHY)    += bcm63xx.o
  obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
  obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
  obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o