imx6: add new target
[openwrt.git] / target / linux / gemini / Makefile
index 6b37d59..3f3f8d5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,10 +9,11 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=gemini
 BOARDNAME:=Cortina Systems CS351x
-FEATURES:=squashfs
-CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
+FEATURES:=squashfs pci
+CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.30.2
+LINUX_VERSION:=3.9.4
 
 include $(INCLUDE_DIR)/target.mk