brcm47xx: various fixes and code cleanups for irq code
[openwrt.git] / target / linux / cns3xxx / Makefile
index ae0ddd9..50c0e94 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=cns3xxx
 BOARDNAME:=Cavium Networks Econa CNS3xxx
-FEATURES:=squashfs fpu gpio
+FEATURES:=squashfs fpu gpio pcie usb usbgadget
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
@@ -24,4 +24,6 @@ endef
 
 KERNELNAME:="uImage"
 
+DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
+
 $(eval $(call BuildTarget))