linux: export bcm963xx_tag.h to userspace
[openwrt.git] / target / linux / brcm63xx / patches-3.3 / 403-MIPS-BCM63XX-register-ehci-device.patch
index 5a13013..8606d41 100644 (file)
@@ -15,13 +15,15 @@ Subject: [PATCH 26/63] MIPS: BCM63XX: register ehci device.
 
 --- a/arch/mips/bcm63xx/Kconfig
 +++ b/arch/mips/bcm63xx/Kconfig
-@@ -22,11 +22,13 @@ config BCM63XX_CPU_6358
+@@ -22,6 +22,7 @@ config BCM63XX_CPU_6358
        bool "support 6358 CPU"
        select HW_HAS_PCI
        select USB_ARCH_HAS_OHCI if USB_SUPPORT
 +      select USB_ARCH_HAS_EHCI if USB_SUPPORT
  
- config BCM63XX_CPU_6368
+ config BCM63XX_CPU_6362
+       bool "support 6362 CPU"
+@@ -31,6 +32,7 @@ config BCM63XX_CPU_6368
        bool "support 6368 CPU"
        select HW_HAS_PCI
        select USB_ARCH_HAS_OHCI if USB_SUPPORT
@@ -33,23 +35,23 @@ Subject: [PATCH 26/63] MIPS: BCM63XX: register ehci device.
 +++ b/arch/mips/bcm63xx/Makefile
 @@ -1,6 +1,6 @@
  obj-y         += clk.o cpu.o cs.o gpio.o irq.o prom.o setup.o timer.o \
-                  dev-dsp.o dev-enet.o dev-flash.o dev-pcmcia.o dev-spi.o \
--                 dev-trng.o dev-uart.o dev-usb-ohci.o dev-wdt.o
-+                 dev-trng.o dev-uart.o dev-usb-ehci.o dev-usb-ohci.o dev-wdt.o
+                  dev-dsp.o dev-enet.o dev-flash.o dev-pcmcia.o dev-rng.o \
+-                 dev-spi.o dev-uart.o dev-usb-ohci.o dev-wdt.o
++                 dev-spi.o dev-uart.o dev-usb-ehci.o dev-usb-ohci.o dev-wdt.o
  obj-$(CONFIG_EARLY_PRINTK)    += early_printk.o
  
  obj-y         += boards/
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -27,6 +27,7 @@
+@@ -28,6 +28,7 @@
  #include <bcm63xx_dev_pcmcia.h>
  #include <bcm63xx_dev_spi.h>
  #include <bcm63xx_dev_usb_ohci.h>
 +#include <bcm63xx_dev_usb_ehci.h>
  #include <board_bcm963xx.h>
- #include <bcm_tag.h>
+ #include <linux/bcm963xx_tag.h>
  
-@@ -912,6 +913,9 @@ int __init board_register_devices(void)
+@@ -917,6 +918,9 @@ int __init board_register_devices(void)
            !board_get_mac_address(board.enet1.mac_addr))
                bcm63xx_enet_register(1, &board.enet1);