bcm63xx: remove bcm_tag usage in kernel
[openwrt.git] / target / linux / brcm63xx / patches-3.3 / 401-MIPS-BCM63XX-register-ohci-device.patch
index 7b213c3..33b1a39 100644 (file)
@@ -15,7 +15,7 @@ Subject: [PATCH 24/63] MIPS: BCM63XX: register ohci device.
 
 --- a/arch/mips/bcm63xx/Kconfig
 +++ b/arch/mips/bcm63xx/Kconfig
-@@ -4,26 +4,25 @@ menu "CPU support"
+@@ -8,22 +8,20 @@ config BCM63XX_CPU_6328
  config BCM63XX_CPU_6338
        bool "support 6338 CPU"
        select HW_HAS_PCI
@@ -39,6 +39,9 @@ Subject: [PATCH 24/63] MIPS: BCM63XX: register ohci device.
        select HW_HAS_PCI
 +      select USB_ARCH_HAS_OHCI if USB_SUPPORT
  
+ config BCM63XX_CPU_6362
+       bool "support 6362 CPU"
+@@ -32,6 +30,7 @@ config BCM63XX_CPU_6362
  config BCM63XX_CPU_6368
        bool "support 6368 CPU"
        select HW_HAS_PCI
@@ -50,23 +53,23 @@ Subject: [PATCH 24/63] MIPS: BCM63XX: register ohci device.
 +++ b/arch/mips/bcm63xx/Makefile
 @@ -1,6 +1,6 @@
  obj-y         += clk.o cpu.o cs.o gpio.o irq.o prom.o setup.o timer.o \
-                  dev-dsp.o dev-enet.o dev-pcmcia.o dev-spi.o dev-trng.o \
--                 dev-uart.o dev-wdt.o
-+                 dev-uart.o dev-usb-ohci.o dev-wdt.o
+                  dev-dsp.o dev-enet.o dev-flash.o dev-pcmcia.o dev-rng.o \
+-                 dev-spi.o dev-uart.o dev-wdt.o
++                 dev-spi.o dev-uart.o dev-usb-ohci.o dev-wdt.o
  obj-$(CONFIG_EARLY_PRINTK)    += early_printk.o
  
  obj-y         += boards/
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -28,6 +28,7 @@
- #include <bcm63xx_dev_dsp.h>
+@@ -27,6 +27,7 @@
+ #include <bcm63xx_dev_flash.h>
  #include <bcm63xx_dev_pcmcia.h>
  #include <bcm63xx_dev_spi.h>
 +#include <bcm63xx_dev_usb_ohci.h>
  #include <board_bcm963xx.h>
- #include <bcm_tag.h>
+ #include <bcm963xx_tag.h>
  
-@@ -943,6 +944,9 @@ int __init board_register_devices(void)
+@@ -916,6 +917,9 @@ int __init board_register_devices(void)
            !board_get_mac_address(board.enet1.mac_addr))
                bcm63xx_enet_register(1, &board.enet1);