brcm47xx: move current target to "generic" subtarget
[openwrt.git] / target / linux / brcm47xx / Makefile
index bad5ec1..fa5d21b 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=brcm47xx
-BOARDNAME:=Broadcom BCM947xx/953xx
-FEATURES:=squashfs usb
+BOARDNAME:=Broadcom BCM47xx/53xx (MIPS)
+FEATURES:=squashfs usb pcmcia low_mem
+SUBTARGETS:=generic
+MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
-LINUX_VERSION:=2.6.25.17
+LINUX_VERSION:=3.10.36
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag
 
-define Target/Description
-       Build firmware images for Broadcom based routers
-       (e.g. Netgear WGT634U)
-endef
+DEFAULT_PACKAGES += swconfig wpad-mini nvram \
+       kmod-leds-gpio kmod-gpio-button-hotplug \
+       kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev
 
 $(eval $(call BuildTarget))