kernel: update 3.10 to 3.10.2
[openwrt.git] / target / linux / brcm2708 / patches-3.10 / 010-bcm2835-thermal-driver.patch
index 80256d0..7e69e8a 100644 (file)
@@ -1,6 +1,5 @@
-diff -urN linux-3.10/drivers/thermal/bcm2835-thermal.c linux-rpi-3.10.y/drivers/thermal/bcm2835-thermal.c
---- linux-3.10/drivers/thermal/bcm2835-thermal.c       1970-01-01 01:00:00.000000000 +0100
-+++ linux-rpi-3.10.y/drivers/thermal/bcm2835-thermal.c 2013-07-06 15:25:50.000000000 +0100
+--- /dev/null
++++ b/drivers/thermal/bcm2835-thermal.c
 @@ -0,0 +1,184 @@
 +/*****************************************************************************
 +* Copyright 2011 Broadcom Corporation.  All rights reserved.
@@ -186,10 +185,9 @@ diff -urN linux-3.10/drivers/thermal/bcm2835-thermal.c linux-rpi-3.10.y/drivers/
 +MODULE_DESCRIPTION("Thermal driver for bcm2835 chip");
 +
 +module_platform_driver(bcm2835_thermal_driver);
-diff -urN linux-3.10/drivers/thermal/Kconfig linux-rpi-3.10.y/drivers/thermal/Kconfig
---- linux-3.10/drivers/thermal/Kconfig 2013-06-30 23:13:29.000000000 +0100
-+++ linux-rpi-3.10.y/drivers/thermal/Kconfig   2013-07-06 15:25:50.000000000 +0100
-@@ -169,4 +169,11 @@
+--- a/drivers/thermal/Kconfig
++++ b/drivers/thermal/Kconfig
+@@ -169,4 +169,11 @@ config INTEL_POWERCLAMP
          enforce idle time which results in more package C-state residency. The
          user interface is exposed via generic thermal framework.
  
@@ -201,10 +199,9 @@ diff -urN linux-3.10/drivers/thermal/Kconfig linux-rpi-3.10.y/drivers/thermal/Kc
 +
  endif
 +
-diff -urN linux-3.10/drivers/thermal/Makefile linux-rpi-3.10.y/drivers/thermal/Makefile
---- linux-3.10/drivers/thermal/Makefile        2013-06-30 23:13:29.000000000 +0100
-+++ linux-rpi-3.10.y/drivers/thermal/Makefile  2013-07-06 15:25:50.000000000 +0100
-@@ -23,4 +23,5 @@
+--- a/drivers/thermal/Makefile
++++ b/drivers/thermal/Makefile
+@@ -23,4 +23,5 @@ obj-$(CONFIG_DB8500_THERMAL) += db8500_t
  obj-$(CONFIG_ARMADA_THERMAL)  += armada_thermal.o
  obj-$(CONFIG_DB8500_CPUFREQ_COOLING)  += db8500_cpufreq_cooling.o
  obj-$(CONFIG_INTEL_POWERCLAMP)        += intel_powerclamp.o