kernel: update 3.10 to 3.10.2
[openwrt.git] / target / linux / brcm2708 / patches-3.10 / 007-bcm2708_hw_random-driver.patch
index 4805326..79ee686 100644 (file)
@@ -1,6 +1,5 @@
-diff -urN linux-3.10/drivers/char/hw_random/bcm2708-rng.c linux-rpi-3.10.y/drivers/char/hw_random/bcm2708-rng.c
---- linux-3.10/drivers/char/hw_random/bcm2708-rng.c    1970-01-01 01:00:00.000000000 +0100
-+++ linux-rpi-3.10.y/drivers/char/hw_random/bcm2708-rng.c      2013-07-06 15:25:50.000000000 +0100
+--- /dev/null
++++ b/drivers/char/hw_random/bcm2708-rng.c
 @@ -0,0 +1,117 @@
 +/**
 + * Copyright (c) 2010-2012 Broadcom. All rights reserved.
@@ -119,10 +118,9 @@ diff -urN linux-3.10/drivers/char/hw_random/bcm2708-rng.c linux-rpi-3.10.y/drive
 +
 +MODULE_DESCRIPTION("BCM2708 H/W Random Number Generator (RNG) driver");
 +MODULE_LICENSE("GPL and additional rights");
-diff -urN linux-3.10/drivers/char/hw_random/Kconfig linux-rpi-3.10.y/drivers/char/hw_random/Kconfig
---- linux-3.10/drivers/char/hw_random/Kconfig  2013-06-30 23:13:29.000000000 +0100
-+++ linux-rpi-3.10.y/drivers/char/hw_random/Kconfig    2013-07-06 15:25:50.000000000 +0100
-@@ -314,3 +314,15 @@
+--- a/drivers/char/hw_random/Kconfig
++++ b/drivers/char/hw_random/Kconfig
+@@ -314,3 +314,15 @@ config HW_RANDOM_TPM
          module will be called tpm-rng.
  
          If unsure, say Y.
@@ -138,10 +136,9 @@ diff -urN linux-3.10/drivers/char/hw_random/Kconfig linux-rpi-3.10.y/drivers/cha
 +
 +       If unsure, say N.
 +
-diff -urN linux-3.10/drivers/char/hw_random/Makefile linux-rpi-3.10.y/drivers/char/hw_random/Makefile
---- linux-3.10/drivers/char/hw_random/Makefile 2013-06-30 23:13:29.000000000 +0100
-+++ linux-rpi-3.10.y/drivers/char/hw_random/Makefile   2013-07-06 15:25:50.000000000 +0100
-@@ -27,3 +27,4 @@
+--- a/drivers/char/hw_random/Makefile
++++ b/drivers/char/hw_random/Makefile
+@@ -27,3 +27,4 @@ obj-$(CONFIG_HW_RANDOM_PSERIES) += pseri
  obj-$(CONFIG_HW_RANDOM_EXYNOS)        += exynos-rng.o
  obj-$(CONFIG_HW_RANDOM_TPM) += tpm-rng.o
  obj-$(CONFIG_HW_RANDOM_BCM2835) += bcm2835-rng.o