kernel: update 3.10 to 3.10.2
[openwrt.git] / target / linux / brcm2708 / patches-3.10 / 003-bcm2708-watchdog-driver.patch
index fb0ea33..f64fe38 100644 (file)
@@ -1,6 +1,5 @@
-diff -urN linux-3.10/drivers/watchdog/bcm2708_wdog.c linux-rpi-3.10.y/drivers/watchdog/bcm2708_wdog.c
---- linux-3.10/drivers/watchdog/bcm2708_wdog.c 1970-01-01 01:00:00.000000000 +0100
-+++ linux-rpi-3.10.y/drivers/watchdog/bcm2708_wdog.c   2013-07-06 15:25:50.000000000 +0100
+--- /dev/null
++++ b/drivers/watchdog/bcm2708_wdog.c
 @@ -0,0 +1,385 @@
 +/*
 + *    Broadcom BCM2708 watchdog driver.
@@ -387,10 +386,9 @@ diff -urN linux-3.10/drivers/watchdog/bcm2708_wdog.c linux-rpi-3.10.y/drivers/wa
 +MODULE_ALIAS_MISCDEV(TEMP_MINOR);
 +MODULE_LICENSE("GPL");
 +
-diff -urN linux-3.10/drivers/watchdog/Kconfig linux-rpi-3.10.y/drivers/watchdog/Kconfig
---- linux-3.10/drivers/watchdog/Kconfig        2013-06-30 23:13:29.000000000 +0100
-+++ linux-rpi-3.10.y/drivers/watchdog/Kconfig  2013-07-06 15:25:50.000000000 +0100
-@@ -391,6 +391,12 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -391,6 +391,12 @@ config RETU_WATCHDOG
          To compile this driver as a module, choose M here: the
          module will be called retu_wdt.
  
@@ -403,10 +401,9 @@ diff -urN linux-3.10/drivers/watchdog/Kconfig linux-rpi-3.10.y/drivers/watchdog/
  # AVR32 Architecture
  
  config AT32AP700X_WDT
-diff -urN linux-3.10/drivers/watchdog/Makefile linux-rpi-3.10.y/drivers/watchdog/Makefile
---- linux-3.10/drivers/watchdog/Makefile       2013-06-30 23:13:29.000000000 +0100
-+++ linux-rpi-3.10.y/drivers/watchdog/Makefile 2013-07-06 15:25:50.000000000 +0100
-@@ -54,6 +54,7 @@
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -54,6 +54,7 @@ obj-$(CONFIG_TS72XX_WATCHDOG) += ts72xx_
  obj-$(CONFIG_IMX2_WDT) += imx2_wdt.o
  obj-$(CONFIG_UX500_WATCHDOG) += ux500_wdt.o
  obj-$(CONFIG_RETU_WATCHDOG) += retu_wdt.o