major target cleanup. it is now possible to have subtargets that can override many...
[openwrt.git] / target / linux / brcm-2.4 / Makefile
index e15eb09..da5cf64 100644 (file)
@@ -6,9 +6,23 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.4.32
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
+ARCH:=mipsel
+BOARD:=brcm-2.4
+BOARDNAME:=Broadcom BCM947xx/953xx
+FEATURES:=squashfs
 
-include $(INCLUDE_DIR)/kernel-build.mk
-$(eval $(call BuildKernel))
+KERNEL:=2.4
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += kmod-switch kmod-diag nvram 
+
+define Target/Description
+       Build firmware images for Broadcom based routers
+       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
+endef
+
+# include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildTarget))