major target cleanup. it is now possible to have subtargets that can override many...
[openwrt.git] / target / linux / au1000 / Makefile
index d7b9f73..f7dcb03 100644 (file)
@@ -13,14 +13,14 @@ FEATURES:=jffs2 usb pci
 
 LINUX_VERSION:=2.6.22.4
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += yamonenv
+
 define Target/Description
        Build firmware for AMD Alchemy 1500 boards
        (e.g. 4G-Systems Mesh/Access Cube ...)
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += yamonenv
-
 define Kernel/BuildImage
        $(call Kernel/BuildImage/Default)
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
@@ -30,5 +30,5 @@ endef
 # include the profiles
 -include profiles/*.mk
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))