imx6: update 3.10 patches
[openwrt.git] / target / linux / at91 / Makefile
index 7a9a1ad..3dac8a4 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,21 +8,15 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
-BOARDNAME:=AT91
-FEATURES:=squashfs usb
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
+BOARDNAME:=Atmel AT91
+FEATURES:=squashfs targz ext2 usb
+CPU_TYPE:=arm926ej-s
 
-#LINUX_VERSION:=2.6.21.5
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=3.8.13
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
-
-define Target/Description
-  Build fimware images for Figment Design Labs VersaLink board.
-endef
-
-#include the profiles
--include profiles/*.mk
+DEFAULT_PACKAGES += kmod-usb-ohci
 
 $(eval $(call BuildTarget))