ar71xx: build image for the TL-MR3220 v2
[openwrt.git] / target / linux / at91 / Makefile
index d90d105..3c7d85b 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
-FEATURES:=squashfs usb
+FEATURES:=squashfs jffs2 targz ext2 usb
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+SUBTARGETS:=9g20 9260 9263
 
-LINUX_VERSION:=2.6.25.19
+LINUX_VERSION:=3.3.8
+DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES+= kmod-usb-ohci
 KERNELNAME:="uImage"
 
-define Target/Description
-  Build fimware images for Figment Design Labs VersaLink board.
-endef
-
 $(eval $(call BuildTarget))