ar71xx: set priority of ath79_wdt to 1
[openwrt.git] / target / linux / ar71xx / modules.mk
index 9b061d5..601f473 100644 (file)
@@ -31,12 +31,28 @@ define KernelPackage/leds-wndr3700-usb
 endef
 
 define KernelPackage/leds-wndr3700-usb/description
- Kernel module for the USB LED on the NETGWR WNDR3700 board.
+ Kernel module for the USB LED on the NETGEAR WNDR3700 board.
 endef
 
 $(eval $(call KernelPackage,leds-wndr3700-usb))
 
 
+define KernelPackage/nand-ar934x
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Atheros AR934x NAND flash controller driver
+  KCONFIG:=CONFIG_MTD_NAND_AR934X
+  DEPENDS:=@TARGET_ar71xx +kmod-nand
+  FILES:=$(LINUX_DIR)/drivers/mtd/nand/ar934x_nfc.ko
+  AUTOLOAD:=$(call AutoLoad,25,ar934x_nfc)
+endef
+
+define KernelPackage/nand-ar934x/description
+  Atheros AR934x NAND flash controller driver.
+endef
+
+$(eval $(call KernelPackage,nand-ar934x))
+
+
 define KernelPackage/spi-vsc7385
   SUBMENU:=$(SPI_MENU)
   TITLE:=Vitesse VSC7385 ethernet switch driver
@@ -51,3 +67,20 @@ define KernelPackage/spi-vsc7385/description
 endef
 
 $(eval $(call KernelPackage,spi-vsc7385))
+
+
+define KernelPackage/wdt-ath79
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Atheros AR7XXX/AR9XXX watchdog timer
+  DEPENDS:=@TARGET_ar71xx
+  KCONFIG:=CONFIG_ATH79_WDT
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/ath79_wdt.ko
+  AUTOLOAD:=$(call AutoLoad,50,ath79_wdt,1)
+endef
+
+define KernelPackage/wdt-ath79/description
+  Kernel module for AR7XXX/AR9XXX watchdog timer.
+endef
+
+$(eval $(call KernelPackage,wdt-ath79))
+