ar71xx: add support for TP-LINK TL-WA860RE v1
[openwrt.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index 7398f4f..d6516fe 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/ARCHERC7
        NAME:=TP-LINK Archer C7
-       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev kmod-ath10k
 endef
 
 define Profile/ARCHERC7/Description
@@ -38,6 +38,17 @@ endef
 $(eval $(call Profile,TLMR11U))
 
 
+define Profile/TLMR13U
+       NAME:=TP-LINK TL-MR13U
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR13U/Description
+       Package set optimized for the TP-LINK TL-MR13U.
+endef
+$(eval $(call Profile,TLMR13U))
+
+
 define Profile/TLMR3020
        NAME:=TP-LINK TL-MR3020
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
@@ -94,6 +105,18 @@ endef
 $(eval $(call Profile,TLWR703))
 
 
+define Profile/TLWR710
+       NAME:=TP-LINK TL-WR710N
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+
+define Profile/TLWR710/Description
+       Package set optimized for the TP-LINK TL-WR710N.
+endef
+$(eval $(call Profile,TLWR710))
+
+
 define Profile/TLWR720
        NAME:=TP-LINK TL-WR720N
        PACKAGES:=kmod-usb-core kmod-usb2
@@ -116,6 +139,27 @@ define Profile/TLWA701/Description
 endef
 $(eval $(call Profile,TLWA701))
 
+define Profile/TLWA730RE
+       NAME:=TP-LINK TL-WA730RE
+       PACKAGES:=
+endef
+
+define Profile/TLWA730RE/Description
+       Package set optimized for the TP-LINK TL-WA730RE.
+endef
+$(eval $(call Profile,TLWA730RE))
+
+define Profile/TLWA750
+       NAME:=TP-LINK TL-WA750RE
+       PACKAGES:=rssileds
+endef
+
+define Profile/TLWA750/Description
+       Package set optimized for the TP-LINK TL-WA750RE.
+endef
+$(eval $(call Profile,TLWA750))
+
+
 define Profile/TLWA7510
        NAME:=TP-LINK TL-WA7510N
        PACKAGES:=
@@ -147,6 +191,28 @@ endef
 $(eval $(call Profile,TLWA830))
 
 
+define Profile/TLWA850
+       NAME:=TP-LINK TL-WA850RE
+       PACKAGES:=rssileds
+endef
+
+define Profile/TLWA850/Description
+       Package set optimized for the TP-LINK TL-WA850RE.
+endef
+$(eval $(call Profile,TLWA850))
+
+
+define Profile/TLWA860
+       NAME:=TP-LINK TL-WA860RE
+       PACKAGES:=
+endef
+
+define Profile/TLWA860/Description
+       Package set optimized for the TP-LINK TL-WA860RE.
+endef
+$(eval $(call Profile,TLWA860))
+
+
 define Profile/TLWA901
        NAME:=TP-LINK TL-WA901N/ND
        PACKAGES:=
@@ -169,6 +235,17 @@ endef
 $(eval $(call Profile,TLWDR4300))
 
 
+define Profile/TLWDR4900V2
+       NAME:=TP-LINK TL-WDR4900v2
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLWDR4900V2/Description
+       Package set optimized for the TP-LINK TL-WDR4900v2.
+endef
+$(eval $(call Profile,TLWDR4900V2))
+
+
 define Profile/TLWR740
        NAME:=TP-LINK TL-WR740N/ND
        PACKAGES:=