ar71xx: Add support for AP147-010 reference board
[openwrt.git] / target / linux / ar71xx / generic / profiles / netgear.mk
index 15a2081..16b1087 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -28,25 +28,57 @@ endef
 $(eval $(call Profile,WNDR3700))
 
 
-define Profile/WNDR4300
-       NAME:=NETGEAR WNDR4300
-       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+define Profile/WNR2000V3
+       NAME:=NETGEAR WNR2000V3
 endef
 
-define Profile/WNDR4300/Description
-       Package set optimized for the NETGEAR WNDR4300
+define Profile/WNR2000V3/Description
+       Package set optimized for the NETGEAR WNR2000V3
 endef
 
-$(eval $(call Profile,WNDR4300))
+$(eval $(call Profile,WNR2000V3))
 
 
-define Profile/WNR2000V3
-       NAME:=NETGEAR WNR2000V3
+define Profile/WNR2000V4
+       NAME:=NETGEAR WNR2000V4
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
-define Profile/WNR2000V3/Description
-       Package set optimized for the NETGEAR WNR2000V3
+define Profile/WNR2000V4/Description
+       Package set optimized for the NETGEAR WNR2000V4
 endef
 
-$(eval $(call Profile,WNR2000V3))
+$(eval $(call Profile,WNR2000V4))
+
+
+define Profile/WNR612V2
+       NAME:=NETGEAR WNR612V2 / On Networks N150
+endef
+
+define Profile/WNR612V2/Description
+       Package set optimized for the NETGEAR WNR612V2 / On Networks N150
+endef
+
+$(eval $(call Profile,WNR612V2))
+
+
+define Profile/WNR1000V2
+       NAME:=NETGEAR WNR1000V2
+endef
+
+define Profile/WNR1000V2/Description
+       Package set optimized for the NETGEAR WNR1000V2
+endef
+
+$(eval $(call Profile,WNR1000V2))
+
+
+define Profile/WNR2200
+       NAME:=NETGEAR WNR2200
+endef
+
+define Profile/WNR2200/Description
+       Package set optimized for the NETGEAR WNR2200
+endef
 
+$(eval $(call Profile,WNR2200))