ar71xx: add profile and build image for the WD My Net N600 board
[openwrt.git] / target / linux / ar71xx / generic / profiles / d-link.mk
index ec79dde..c9724c2 100644 (file)
@@ -5,6 +5,17 @@
 # See /LICENSE for more information.
 #
 
+define Profile/DIR505A1
+       NAME:=D-Link DIR-505 rev. A1
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/DIR505A1/Description
+       Package set optimized for the D-Link DIR-505 rev. A1.
+endef
+
+$(eval $(call Profile,DIR505A1))
+
 define Profile/DIR600A1
        NAME:=D-Link DIR-600 rev. A1
        PACKAGES:=
@@ -16,6 +27,27 @@ endef
 
 $(eval $(call Profile,DIR600A1))
 
+define Profile/DIR601A1
+       NAME:=D-Link DIR-601 rev. A1
+       PACKAGES:=
+endef
+
+define Profile/DIR601A1/Description
+       Package set optimized for the D-Link DIR-601 rev. A1.
+endef
+
+$(eval $(call Profile,DIR601A1))
+
+define Profile/DIR601B1
+       NAME:=D-Link DIR-601 rev. B1
+       PACKAGES:=
+endef
+
+define Profile/DIR601B1/Description
+       Package set optimized for the D-Link DIR-601 rev. B1.
+endef
+
+$(eval $(call Profile,DIR601B1))
 
 define Profile/DIR615C1
        NAME:=D-Link DIR-615 rev. C1
@@ -29,6 +61,18 @@ endef
 $(eval $(call Profile,DIR615C1))
 
 
+define Profile/DIR615E4
+       NAME:=D-Link DIR-615 rev. E4
+       PACKAGES:=
+endef
+
+define Profile/DIR615E4/Description
+       Package set optimized for the D-Link DIR-615 rev. E4.
+endef
+
+$(eval $(call Profile,DIR615E4))
+
+
 define Profile/DIR825B1
        NAME:=D-Link DIR-825 rev. B1
        PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
@@ -39,3 +83,25 @@ define Profile/DIR825B1/Description
 endef
 
 $(eval $(call Profile,DIR825B1))
+
+define Profile/DIR825C1
+       NAME:=D-Link DIR-825 rev. C1
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/DIR825C1/Description
+       Package set optimized for the D-Link DIR-825 rev. C1.
+endef
+
+$(eval $(call Profile,DIR825C1))
+
+define Profile/DIR835A1
+       NAME:=D-Link DIR-835 rev. A1
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/DIR835A1/Description
+       Package set optimized for the D-Link DIR-835 rev. A1.
+endef
+
+$(eval $(call Profile,DIR835A1))