ar71xx: rb2011: use board name from the hardware config
[openwrt.git] / target / linux / ar71xx / generic / profiles / buffalo.mk
index 411dec6..80e7192 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -16,6 +16,17 @@ endef
 
 $(eval $(call Profile,WZRHPG300NH))
 
+define Profile/WZRHPG300NH2
+       NAME:=Buffalo WZR-HP-G300NH2
+       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WZRHPG300NH/Description
+       Package set optimized for the Buffalo WZR-HP-G300NH2
+endef
+
+$(eval $(call Profile,WZRHPG300NH2))
+
 define Profile/WZRHPAG300H
        NAME:=Buffalo WZR-HP-AG300H
        PACKAGES:=kmod-usb-ohci kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
@@ -27,6 +38,40 @@ endef
 
 $(eval $(call Profile,WZRHPAG300H))
 
+define Profile/WZRHPG450H
+       NAME:=Buffalo WZR-HP-G450H
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WZRHPG450H/Description
+       Package set optimized for the Buffalo WZR-HP-G450H
+endef
+
+$(eval $(call Profile,WZRHPG450H))
+
+define Profile/WZR600DHP
+       NAME:=Buffalo WZR-600DHP
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WZR600DHP/Description
+       Package set optimized for the Buffalo WZR-600DHP
+endef
+
+$(eval $(call Profile,WZR600DHP))
+
+define Profile/WHRG301N
+       NAME:=Buffalo WHR-G301N
+       PACKAGES:=
+endef
+
+define Profile/WHRG301N/Description
+       Package set optimized for the Buffalo WHR-G301N.
+endef
+
+$(eval $(call Profile,WHRG301N))
+
+
 define Profile/WHRHPG300N
        NAME:=Buffalo WHR-HP-G300N
        PACKAGES:=
@@ -37,3 +82,26 @@ define Profile/WHRHPG300N/Description
 endef
 
 $(eval $(call Profile,WHRHPG300N))
+
+
+define Profile/WHRHPGN
+       NAME:=Buffalo WHR-HP-GN
+       PACKAGES:=
+endef
+
+define Profile/WHRHPGN/Description
+       Package set optimized for the Buffalo WHR-HP-GN.
+endef
+
+$(eval $(call Profile,WHRHPGN))
+
+define Profile/WLAEAG300N
+       NAME:=Buffalo WLAE-AG300N
+       PACKAGES:=kmod-ledtrig-netdev
+endef
+
+define Profile/WLAEAG300N/Description
+       Package set optimized for the Buffalo WLAE-AG300N
+endef
+
+$(eval $(call Profile,WLAEAG300N))