rpcd: iwinfo plugin fixes
[openwrt.git] / target / linux / ar71xx / generic / profiles / antminer.mk
index 366982c..0b15507 100644 (file)
@@ -5,13 +5,35 @@
 # See /LICENSE for more information.
 #
 
-define Profile/ANTMINER_S1
-       NAME:=Antminer S1
+define Profile/ANTMINERS1
+       NAME:=Antminer-S1
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-crypto-manager kmod-i2c-gpio-custom kmod-usb-hid
 endef
 
 
-define Profile/ANTMINER_S1/Description
+define Profile/ANTMINERS1/Description
        Package set optimized for the Bitmain Antminer S1.
 endef
-$(eval $(call Profile,ANTMINER_S1))
+$(eval $(call Profile,ANTMINERS1))
+
+define Profile/ANTMINERS3
+       NAME:=Antminer-S3
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-crypto-manager kmod-i2c-gpio-custom kmod-usb-hid
+endef
+
+
+define Profile/ANTMINERS3/Description
+       Package set optimized for the Bitmain Antminer S3.
+endef
+$(eval $(call Profile,ANTMINERS3))
+
+define Profile/ANTROUTERR1
+       NAME:=Antrouter-R1
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+
+define Profile/ANTROUTERR1/Description
+       Package set optimized for the Bitmain Antrouter R1.
+endef
+$(eval $(call Profile,ANTROUTERR1))