ar71xx: Add QCA955X GPIO mux and function definitions
[openwrt.git] / target / linux / ar71xx / Makefile
index b223c40..24d7d5c 100644 (file)
@@ -8,21 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx/AR7240/AR913x/AR934x
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-SUBTARGETS:=generic nand
+BOARDNAME:=Atheros AR7xxx/AR9xxx
+FEATURES:=mips16
+CPU_TYPE=34kc
+SUBTARGETS:=generic nand mikrotik
 
-LINUX_VERSION:=2.6.37.6
+KERNEL_PATCHVER:=4.1
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-keys-polled kmod-button-hotplug swconfig
-
-define Target/Description
-       Build firmware images for Atheros AR71xx/AR913x/AR934x based boards.
-endef
+       kmod-gpio-button-hotplug swconfig \
+       kmod-ath9k wpad-mini uboot-envtools
 
 $(eval $(call BuildTarget))