kernel: update 3.10 to 3.10.17
[openwrt.git] / target / linux / ar7 / Makefile
index f5c6b99..74321a2 100644 (file)
@@ -1,5 +1,5 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=ar7
 BOARDNAME:=TI AR7
-FEATURES:=squashfs jffs2 atm
+FEATURES:=squashfs atm
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+SUBTARGETS:=generic ac49x
 
-LINUX_VERSION:=2.6.25.4
+LINUX_VERSION:=3.10.17
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES+= swconfig
+
 define Target/Description
-       Build firmware images for TI AR7 based routers
+       Build firmware images for TI AR7 based routers.
 endef
 
 $(eval $(call BuildTarget))