update targets to 2.6.25.10
[openwrt.git] / target / linux / adm5120 / Makefile
index 4cc10ef..f96a5ce 100644 (file)
@@ -8,13 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
-BOARDNAME:=Infineon ADM5120
-LINUX_VERSION:=2.6.24.5
+BOARDNAME:=Infineon/ADMtek ADM5120
+LINUX_VERSION:=2.6.25.10
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += admswconfig
+DEFAULT_PACKAGES += \
+       kmod-input-core \
+       kmod-input-polldev \
+       kmod-input-gpio-buttons \
+       kmod-button-hotplug
 
 $(eval $(call BuildTarget))