[adm5120] use 2.6.27.11 kernel
[openwrt.git] / target / linux / adm5120 / Makefile
index 34c3b80..5a5c5ab 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
-LINUX_VERSION:=2.6.22.4
-FEATURES:=squashfs jffs2 tgz broken
+BOARDNAME:=Infineon/ADMtek ADM5120
+LINUX_VERSION:=2.6.27.11
+SUBTARGETS:=router_le router_be
+INITRAMFS_EXTRA_FILES:=
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += admswconfig
+DEFAULT_PACKAGES += admswconfig hostapd-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug
 
-$(eval $(call Target,router_be))
-$(eval $(call Target,router_le))
 $(eval $(call BuildTarget))