lantiq: use dwc2 by default on all ar9 boards
[openwrt.git] / target / linux / adm5120 / Makefile
index f8436c0..419c534 100644 (file)
@@ -1,27 +1,24 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 
-ARCH:=mipsel
 BOARD:=adm5120
-BOARDNAME:=ADM5120 (Little Endian)
-FEATURES:=squashfs jffs2 tgz broken
-
-LINUX_VERSION:=2.6.22.4
+BOARDNAME:=Infineon/ADMtek ADM5120
+FEATURES:=low_mem
+SUBTARGETS:=router_le router_be rb1xx
+INITRAMFS_EXTRA_FILES:=
 
-define Target/Description
-       Build firmware images for Infineon/ADMtek ADM5120 based boards
-       (e.g : RouterBoard RB1xx, Compex WP54G-WRT ...)
-endef
+KERNEL_PATCHVER:=3.18
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += admswconfig
+include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
+DEFAULT_PACKAGES += admswconfig wpad-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-keys-polled kmod-button-hotplug \
+                   kmod-leds-gpio kmod-ledtrig-adm5120-switch
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))